<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Obits</title>
<meta name='robots' content='max-image-preview:large' />

			<style type="text/css">
				.slide-excerpt { width: 100%; }
				.slide-excerpt { top: 0; }
				.slide-excerpt { left: 0; }
				.flexslider { max-width: 737px; max-height: 400px; }
				.slide-image { max-height: 400px; }
			</style><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Citizen Voice &amp; Times &raquo; Feed" href="http://www.cvt-news.com/news/?feed=rss2" />
<link rel="alternate" type="application/rss+xml" title="Citizen Voice &amp; Times &raquo; Comments Feed" href="http://www.cvt-news.com/news/?feed=comments-rss2" />
<link rel="canonical" href="http://www.cvt-news.com/news/?p=14438" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.cvt-news.com\/news\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.4"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='bar_style-css'  href='http://www.cvt-news.com/news/wp-content/plugins/banner-ads-rotator/css/style.css?ver=5.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-color-picker-css'  href='http://www.cvt-news.com/news/wp-admin/css/color-picker.min.css?ver=5.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='ParaAdmin-css'  href='http://www.cvt-news.com/news/wp-content/plugins/banner-ads-rotator/ParaAdmin/css/ParaAdmin.css?ver=5.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='ParaDashboard-css'  href='http://www.cvt-news.com/news/wp-content/plugins/banner-ads-rotator/ParaAdmin/css/ParaDashboard.css?ver=5.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='news-pro-theme-css'  href='http://www.cvt-news.com/news/wp-content/themes/news-pro/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.cvt-news.com/news/wp-includes/css/dist/block-library/style.min.css?ver=5.9.4' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='dashicons-css'  href='http://www.cvt-news.com/news/wp-includes/css/dashicons.min.css?ver=5.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-tabs-stylesheet-css'  href='http://www.cvt-news.com/news/wp-content/plugins/genesis-tabs-extended/style.css?ver=5.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='http://www.cvt-news.com/news/wp-content/plugins/genesis-responsive-slider/assets/style.css?ver=1.0.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.cvt-news.com/news/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='http://www.cvt-news.com/news/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='bar_js-js-extra'>
/* <![CDATA[ */
var bar_ajax = {"bar_ajaxurl":"http:\/\/www.cvt-news.com\/news\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.cvt-news.com/news/wp-content/plugins/banner-ads-rotator/js/scripts.js?ver=5.9.4' id='bar_js-js'></script>
<script type='text/javascript' src='http://www.cvt-news.com/news/wp-content/plugins/banner-ads-rotator/ParaAdmin/js/ParaAdmin.js?ver=5.9.4' id='ParaAdmin-js'></script>
<script type='text/javascript' src='http://www.cvt-news.com/news/wp-content/themes/news-pro/js/responsive-menu.js?ver=1.0.0' id='news-responsive-menu-js'></script>
<link rel="https://api.w.org/" href="http://www.cvt-news.com/news/index.php?rest_route=/" /><link rel="alternate" type="application/json" href="http://www.cvt-news.com/news/index.php?rest_route=/wp/v2/posts/14438" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.cvt-news.com/news/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://www.cvt-news.com/news/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.cvt-news.com%2Fnews%2F%3Fp%3D14438" />
<link rel="alternate" type="text/xml+oembed" href="http://www.cvt-news.com/news/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.cvt-news.com%2Fnews%2F%3Fp%3D14438&#038;format=xml" />
<link rel="icon" href="http://www.cvt-news.com/news/wp-content/themes/news-pro/images/favicon.ico" />
<style type="text/css">.site-title a { background: url(http://www.cvt-news.com/news/wp-content/uploads/2015/03/CVT-logo.jpg) no-repeat !important; }</style>
</head>
<body class="post-template-default single single-post postid-14438 single-format-standard custom-header header-image full-width-content genesis-breadcrumbs-visible genesis-footer-widgets-hidden news-pro-blue" itemscope itemtype="https://schema.org/WebPage"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="site-container"><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-secondary-menu-pages" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-8893" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8893"><a href="http://www.cvt-news.com/news/?page_id=6" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li id="menu-item-8894" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8894"><a href="http://www.cvt-news.com/news/?page_id=71" itemprop="url"><span itemprop="name">Advertising</span></a></li>
<li id="menu-item-8895" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8895"><a href="http://www.cvt-news.com/news/?page_id=73" itemprop="url"><span itemprop="name">Subscriptions</span></a></li>
</ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><h1 class="site-title" itemprop="headline"><a href="http://www.cvt-news.com/news/">Citizen Voice &amp; Times</a></h1><h2 class="site-description" itemprop="description">Proudly serving Irvine, Ravenna and Estill County</h2></div><div class="widget-area header-widget-area"><section id="search-5" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="http://www.cvt-news.com/news/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="http://www.cvt-news.com/news/?s={s}" itemprop="target"></form></div></section>
</div></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-primary-menu-categories" class="menu genesis-nav-menu menu-primary"><li id="menu-item-8883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8883"><a href="http://www.cvt-news.com/news/?cat=5" itemprop="url"><span itemprop="name">Local News</span></a></li>
<li id="menu-item-8884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8884"><a href="http://www.cvt-news.com/news/?cat=4" itemprop="url"><span itemprop="name">Lifestyles</span></a></li>
<li id="menu-item-8885" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8885"><a href="http://www.cvt-news.com/news/?cat=12" itemprop="url"><span itemprop="name">Community</span></a></li>
<li id="menu-item-8886" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8886"><a href="http://www.cvt-news.com/news/?cat=6" itemprop="url"><span itemprop="name">Obituaries</span></a></li>
<li id="menu-item-8887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8887"><a href="http://www.cvt-news.com/news/?cat=16" itemprop="url"><span itemprop="name">Schools</span></a></li>
<li id="menu-item-8888" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8888"><a href="http://www.cvt-news.com/news/?cat=8" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li id="menu-item-8889" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8889"><a href="http://www.cvt-news.com/news/?cat=17" itemprop="url"><span itemprop="name">Editorial</span></a></li>
<li id="menu-item-8890" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8890"><a href="http://www.cvt-news.com/news/?cat=14" itemprop="url"><span itemprop="name">Church</span></a></li>
<li id="menu-item-9072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9072"><a href="http://www.cvt-news.com/news/?cat=72" itemprop="url"><span itemprop="name">Outdoors</span></a></li>
<li id="menu-item-8891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8891"><a href="http://www.cvt-news.com/news/?cat=19" itemprop="url"><span itemprop="name">Courts</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="http://www.cvt-news.com/news/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="http://www.cvt-news.com/news/?cat=6" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Obituaries</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> Obits</div><article class="post-14438 post type-post status-publish format-standard category-obits entry" aria-label="Obits" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Obits</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2022-09-02T11:59:00-04:00">September 2, 2022</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://www.cvt-news.com/news/?author=1" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">admin</span></a></span>  </p></header><div class="entry-content" itemprop="text">
<p>Tommie Russell Kendall, age 69, of Willow Tree Lane in Ravenna, passed away Saturday, August 27, 2022, at Baptist Health in Lexington following a long illness. He was born February 17, 1953, and was the son of the late Selbert and Martha Jones Kendall. He was a former member of the National Guard and worked for Central State Hospital. He was a member of the Turning Point Apostolic Pentecostal Church in Clay City. He had lived in Estill County for the last 15 years.&nbsp;</p>



<p>wHe is survived by his wife Judith Gail Collins Kendall; one daughter Crystal (Eddie) Meece of Estill Co.; one sister Patsy Colyer of Shelbyville; one brother Joe Kendall of Shelbyville; and four grandchildren: Gage Hunt, Tyra Hunt, Corey Bishop, and Dalton Bishop.</p>



<p>In addition to his parents, he was preceded in death by one son Larry Hunt Jr., and one brother, David Kendall.&nbsp;</p>



<p>Funeral services were conducted Tuesday, August 30, at the Warren F. Toler Funeral Home Chapel with Bro. Eugene McIntosh officiating. Burial was at the Cobb Hill Cemetery.&nbsp;</p>



<p>Pallbearers were Corey Bishop, Dalton Bishop, Eddie Meece, George Stidham, Tim Stidham, and Doug Flannery.</p>



<p></p>



<p>Ronnie Lynn Henry, age 73, of Maupin Hill Road in Irvine, passed away Thursday, August 25, 2022, at the Marcum &amp; Wallace Memorial Hospital following a long illness. He was born May 5, 1949, in Estill County and was the son of Johnnie M. and Clara Cooper Henry. He served in the United States Marine Corps during the Vietnam Era and was a retired military contractor. He had lived in Estill County most of his life.&nbsp;</p>



<p>He is survived by his daughter Kim Henry of Estill Co.; his son Billy Henry of Estill Co.; and one sister Linda Murphy of Madison Co.</p>



<p>In addition to his parents, he was preceded in death by his wife, Shelia Worrell Henry; his brother Larry Henry, and his half-sister Carolyn Sue Beckett.</p>



<p>Funeral services were conducted Monday, August 29, at the Warren F. Toler Funeral Home Chapel with Bro. Glenn Woosley officiating.</p>



<p></p>



<p></p>



<p></p>



<p>We are sad to announce that Louis Smith Officer, aged 81, of Ravenna Kentucky passed away on August 28th, 2022 in his home after a long illness. He was raised by Ollie and Dorcas Orr, and is preceded in death by nine brothers and sisters: Kate Harper, Timothy Officer, Pearl Rhoades, Estelle Kopp, Thomas Officer, Charles Officer, Harvey Officer, John Officer, and Betty Officer; father Harvey Officer, mother Mettie McCoy, and son Gary Michael Alexander (widow Pamela Sutcliffe). He is survived by his brother Edgar Orr (Billie); ex-wife Penny Officer; three children: Shannon Vice, Christina Officer, and Steven (Susie) Officer; nine grandchildren: Tawny (Johnny) McCauley-Vice, Chelsea (Floyd) Bailey, Christine (Caleb) Caudill, Carol Alexander, Elisha Rose, Kyle Kelly, Danielle Officer, Dylan Officer, and Skylar Officer; and 9 great grandchildren: Zoey Caudill, Aubriegh Caudill, Ivy Caudill, Mia McCauley-Vice, Ava McCauley-Vice, Michael Bailey, Gary Alexander, Eliza Osborne, and Allison Osborne. <br>Louis attended Ravenna Grade School and was a graduate of Irvine High School. After graduating, he went on to serve in the United States Navy where he retired after twenty years of service. He then found employment at the Veterans Affairs Hospital in Lexington Kentucky where he later retired. He was actively involved in the American Legion where he served as Post 79 Commander (3 times), 7th District Adjunct and Vice Commander (2 times), and Sergeant At Arms. He was the Area B Vice Commander, Senior Vice Commander, the State Commander from 2005 to 2006, the Chef de Gare in Volare 1407 (3 times); Grand Chef De Gare for the State of Kentucky, City of Paduah Kentucky Duke of Paduah, Commonwealth of Kentucky Kentucky Colonel, and was a service officer. During his time with the American Legion, he was the recipient of the Distinguished Service Award. <br>      He was an avid outdoorsman, but above all he enjoyed spending time with his kids and grandchildren. His love of life was contagious, and his sense of humor was unparalleled. The man was larger than life, and he will be sorely missed by all who knew and loved him. <br>Funeral services will be conducted Saturday, September 3, at 11 a.m. at the Warren F. Toler Funeral Home with Bro. Marvin Neal officiating. Visitation will be Friday from 6 to 9 p.m. Burial will be at the Kentucky Veterans Cemetery North East on Tuesday, September 6, at 10:30 a.m..<br>     In lieu of flowers, the family requests that donations be made to Estill County Toys for Tots, or the American Legion Post 79 Flood Fund. </p>



<p></p>



<p>Johnnie Wayne Manuel, the husband of Mrs. Irma Lee Deaton Manuel of Mt. Sterling, Kentucky, and the son of Mrs. Geneva Lee Shull Manuel of Hudson, North Carolina and the late Vernie Washington Manuel, was born in Bristol, Virginia on December 5, 1948 and departed this life in Mt. Sterling on May 20, 2022 at the age of 73 years, 5 months and 15 days. He was a retired purchasing officer for the Department of Military Affairs Kentucky Logistics and was a member of the Reid Village Baptist Church.</p>



<p>In addition to his wife Irma, and his mother Geneva, Mr. Manuel is survived by two daughters, Alison Manuel of Damascus, Virginia and Meredith Manuel of Louisville, Kentucky; three grandchildren; one great-grandchild; a nephew, Leon Manuel of Hudson; a niece, Watasha Manuel of Spruce Pine, North Carolina; a special niece, Jade Harrison; two special great nieces, Lauryn Harrison and Zaelynn English; several special brother and sister in-laws; and a host of other relatives and friends.</p>



<p>Mr. Manuel was preceded in death by his father; and two brothers, Steve and Scott Manuel.</p>



<p><em> John Manuel worked as an engineer at Carhartt in Irvine for 15 years.</em></p>



<p></p>



<p>Elsie Estes Kirby, the daughter of the late Masco Estes and Addie Bee Estes, passed peacefully in her sleep on August 22, 2022. She was a retired employee of Carhartt and a lifelong resident of Estill County. She was preceded in death by her husband of 53 years, Richard Charles Kirby, and her daughter, Teresa Gail Kirby-Raglin. She was a member of Thomas Baptist Church.</p>



<p>Elsie is survived by her daughter, Charlotte Kirby, of London, Ky.; sons Charles S. Kirby (Mary), of Waco, Ky and Anthony W. Kirby (Hope Willis), of Irvine, Ky; son-in-law, Darin Raglin, Midway, Ky; grandchildren Katelynn Kirby, Kendall Kirby, Elizabeth Raglin, and Hannah Raglin. Siblings Geneva Philbeck, of Hamilton, Ohio, Kenneth Estes, of Irvine, Ky, and Delbert Estes of Irvine, Ky. Elsie is also survived by her best friend of 50+ years, Teresa Phoenix (Larry), and Cheryl Smith (Steve Masters), whom she loved dearly and always thought of as her baby sister.&nbsp;</p>



<p>In addition to her parents, husband, and daughter, she was preceded in death by her siblings, Eva Mae Miller, Roscoe Estes, Samuel Estes, Obed Estes, Eunice Robertson, Beverly Estes, Reva Hardy, and Michael Estes.&nbsp;</p>



<p>Elsie will be fondly remembered especially for her sense of humor, work ethic, cooking and deep love of family and friends.&nbsp;</p>



<p>Funeral services were held at the Warren F. Toler Funeral Home with Brother Mike Creech and Brother Brett Benton officiating.  She was interred at West Irvine Cemetery in Irvine, KY. </p>



<p></p>



<p>Vicki Lynn Davis, age 61, of Sandhill Road in Irvine, passed away Monday, August 22, 2022, at the Marcum &amp; Wallace Memorial Hospital following a sudden illness. She was born April 10, 1961, in Estill County and was the daughter of James Wesley and Beulah Mae Tipton. She was a homemaker and had lived in Estill County all her life.&nbsp;</p>



<p>She is survived by her husband Edward Leon Davis; two sons: Eric Caton Davis of Estill Co. and Christopher Tyler Davis of Estill Co.; and four grandchildren: Sya Raylene Layken Davis, Bryce Adams, Zoe Adams and Gavin Trent Profitt.</p>



<p>She was preceded in death by her parents, her sister Teresa Joe Sparks, and two brothers, James Ricky Tipton and Darrell Glenn Tipton.</p>



<p>A memorial service will be held at a later date. The Warren F. Toler Funeral Home is in charge of arrangements.&nbsp;</p>
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://www.cvt-news.com/news/?cat=6" rel="category">Obituaries</a></span> </p></footer></article></main></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2022 · <a href="http://my.studiopress.com/themes/news/">News Pro Theme</a> on <a href="https://www.studiopress.com/">Genesis Framework</a> · <a href="https://wordpress.org/">WordPress</a> · <a href="http://www.cvt-news.com/news/wp-login.php">Log in</a></p></div></footer></div><script language='JavaScript' type='text/javascript' src='http://kypress.us/phpadsnew/adx.js'></script>
<script language='JavaScript' type='text/javascript'>
<!--
if (!document.phpAds_used) document.phpAds_used = ',';
phpAds_random = new String (Math.random()); phpAds_random = phpAds_random.substring(2,11);

document.write ("<" + "script language='JavaScript' type='text/javascript' src='");
document.write ("http://kypress.us/phpadsnew/adjs.php?n=" + phpAds_random);
document.write ("&clientid=6");
document.write ("&exclude=" + document.phpAds_used);
if (document.referrer)
document.write ("&referer=" + escape(document.referrer));
document.write ("'><" + "/script>");
//-->
</script>
<noscript>
<a href='http://kypress.us/phpadsnew/adclick.php?n=a39501b2' target='_blank'><img src='http://kypress.us/phpadsnew/adview.php?clientid=6&n=a39501b2' border='0' alt=''></a>
</noscript><script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "fade",directionNav: 0,controlNav: 1,animationDuration: 800,slideshowSpeed: 4000    });  });</script><script type='text/javascript' src='http://www.cvt-news.com/news/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='http://www.cvt-news.com/news/wp-includes/js/jquery/ui/tabs.min.js?ver=1.13.1' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' src='http://www.cvt-news.com/news/wp-content/plugins/genesis-responsive-slider/assets/js/jquery.flexslider.js?ver=1.0.1' id='flexslider-js'></script>
<script type="text/javascript">jQuery(document).ready(function($) { $(".ui-tabs").tabs(); });</script>
</body></html>
